Vigor 2960

Firmware Information
Current Version

1.5.1.4

Release Notes

Release Date 30/05/2022
Support Language English

IMPORTANT NOTE :
Do not upgrade directly from 1.0.5 (and earlier) to 1.5.1.4.

Due to differences in the Web UI and functionality the router MUST first be upgraded to at least 1.0.7.1 prior to upgrading to 1.5.1.4.

Upgrade your router to Version 1.0.7.1 or later first, and afterwards upgrade the router to Version 1.5.1.4.

 

Model Search:
MD5 Checksum : 5410d32a7f62a14d7c7e70215d2fe9a8            SHA1 Checksum : 6db3b73ce82f9e226e19db9211058078a11f39f3
MD5 Checksum : 20ef7ef9f9837364f9288c6553ae7ec6            SHA1 Checksum : 3c71d2f11899d044f6f8d86be811260d7a2154ee
MD5 Checksum : 780b509e3ba6d808b9392691c4a6080b            SHA1 Checksum : 86dc38e64742d21dc9a2ea44bd546200edf1bd48
MD5 Checksum : 03398aef88f5333ce4a860c857f56977            SHA1 Checksum : 0f6f865bcb3cd1dc6a5da0875ee28465e36aa032
folder.png Older Firmware
Files: 40

The resources on these pages are for users in the UK and Ireland only. If you are outside of the UK/Ireland, please contact your local supplier, the local support resource in your country or use the DrayTek International site instead

Resources

Community

Visit the user's forum

Visit

Support Articles

Search for Articles

Find Answers

Warranty

Warranty Information

More info

Contact Support

Contact Us

Get Help